<!doctype html><html lang="en"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><title>Somerville with Townie Tim: Getting around - The Tufts Daily</title><link rel="canonical" href="https://tuftsdaily.com/features/2019/11/06/somerville-townie-tim-getting-around/" /><link rel="publisher" href="https://plus.google.com/+Tuftsdailynewspaper/posts"/><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Somerville with Townie Tim: Getting around - The Tufts Daily" /><meta property="og:description" content="Sometimes this column is just a local townie going on a curmudgeonly rant, and that is totally going to be the case this week. Just make sure you remember the following column is my mostly sarcastic way of getting some catharsis from frustrating situations. In this case, it&#8217;s not you, it&#8217;s not me, it&#8217;s the &hellip;" /><meta property="og:url" content="https://tuftsdaily.com/features/2019/11/06/somerville-townie-tim-getting-around/" /><meta property="og:site_name" content="The Tufts Daily" /><meta property="article:publisher" content="https://www.facebook.com/thetuftsdaily" /><meta property="article:tag" content="Somerville" /><meta property="article:tag" content="Davis Square" /><meta property="article:tag" content="Boston" /><meta property="article:tag" content="Green Light" /><meta property="article:tag" content="Somerville with Townie Tim" /><meta property="article:tag" content="Townie Tim" /><meta property="article:tag" content="Nate Rubright" /><meta property="article:tag" content="Highland Avenue" /><meta property="article:tag" content="horse trenches" /><meta property="article:tag" content="pedestrians" /><meta property="article:section" content="Features" /><meta property="article:published_time" content="2019-11-06T02:00:39-05:00" /><meta property="article:modified_time" content="2019-11-06T01:25:52-05:00" /><meta property="og:updated_time" content="2019-11-06T01:25:52-05:00" /><meta property="og:image" content="http://tuftsdaily.com/wp-content/uploads/2015/01/22269_280777534188_2951374_n.jpg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Sometimes this column is just a local townie going on a curmudgeonly rant, and that is totally going to be the case this week. Just make sure you remember the following column is my mostly sarcastic way of getting some catharsis from frustrating situations. In this case, it&#8217;s not you, it&#8217;s not me, it&#8217;s the [&hellip;]" /><meta name="twitter:title" content="Somerville with Townie Tim: Getting around - The Tufts Daily" /><meta name="twitter:site" content="@tuftsdaily" /><meta name="twitter:image" content="http://tuftsdaily.com/wp-content/uploads/2015/01/22269_280777534188_2951374_n.jpg" /><meta name="twitter:creator" content="@tuftsdaily" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/tuftsdaily.com\/","name":"The Tufts Daily","potentialAction":{"@type":"SearchAction","target":"https:\/\/tuftsdaily.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <link rel='dns-prefetch' href='//cdn.broadstreetads.com' /><link rel='dns-prefetch' href='//code.jquery.com' /><link rel='dns-prefetch' href='//cdnjs.cloudflare.com' /><link rel='dns-prefetch' href='//stackpath.bootstrapcdn.com' /><link rel='dns-prefetch' href='//use.fontawesome.com' /><link rel="alternate" type="application/rss+xml" title="The Tufts Daily &raquo; Somerville with Townie Tim: Getting around Comments Feed" href="https://tuftsdaily.com/features/2019/11/06/somerville-townie-tim-getting-around/feed/" /><link rel='stylesheet' id='simple-banner-style-css'  href='https://tuftsdaily.com/wp-content/plugins/simple-banner/simple-banner.css?ver=4.7.14' type='text/css' media='all' /><link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://tuftsdaily.com/wp-content/plugins/wordpress-popular-posts/public/css/wpp.css?ver=4.2.0' type='text/css' media='all' /><link rel='stylesheet' id='contact-form-7-css'  href='https://tuftsdaily.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9.1' type='text/css' media='all' /><link rel='stylesheet' id='ai-core-style-css'  href='https://tuftsdaily.com/wp-content/plugins/aesop-story-engine/public/assets/css/ai-core.css?ver=1' type='text/css' media='all' /><style id='ai-core-style-inline-css' type='text/css'>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</style><link rel='stylesheet' id='bootstrap-css'  href='https://stackpath.bootstrapcdn.com/bootstrap/4.1.0/css/bootstrap.min.css?ver=4.7.14' type='text/css' media='all' /><link rel='stylesheet' id='fa-css'  href='https://use.fontawesome.com/releases/v5.3.1/css/all.css?ver=4.7.14' type='text/css' media='all' /><link rel='stylesheet' id='header-css'  href='https://tuftsdaily.com/wp-content/themes/tuftsdaily/css/header.css?ver=4.7.14' type='text/css' media='all' /> <script type='text/javascript' src='https://tuftsdaily.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> <script type='text/javascript' src='https://tuftsdaily.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> <script type='text/javascript' src='https://tuftsdaily.com/wp-content/plugins/simple-banner/simple-banner.js?ver=4.7.14'></script> <script type='text/javascript'>var wpp_params={"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/tuftsdaily.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"226558","token":"3c6d921642","debug":""};</script> <script type='text/javascript' src='https://tuftsdaily.com/wp-content/plugins/wordpress-popular-posts/public/js/wpp-4.2.0.min.js?ver=4.2.0'></script> <script type='text/javascript' data-cfasync='false' async src='//cdn.broadstreetads.com/init-2.min.js?ver=4.7.14'></script> <link rel='https://api.w.org/' href='https://tuftsdaily.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tuftsdaily.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tuftsdaily.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 4.7.14" /><link rel='shortlink' href='https://tuftsdaily.com/?p=226558' /><link rel="alternate" type="application/json+oembed" href="https://tuftsdaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftuftsdaily.com%2Ffeatures%2F2019%2F11%2F06%2Fsomerville-townie-tim-getting-around%2F" /><link rel="alternate" type="text/xml+oembed" href="https://tuftsdaily.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftuftsdaily.com%2Ffeatures%2F2019%2F11%2F06%2Fsomerville-townie-tim-getting-around%2F&#038;format=xml" /> <script type='text/javascript'>SG_POPUPS_QUEUE=[];SG_POPUP_DATA=[];SG_APP_POPUP_URL='https://tuftsdaily.com/wp-content/plugins/popup-builder';SG_POPUP_VERSION='2.674_1;';function sgAddEvent(element,eventName,fn){if(element.addEventListener)
element.addEventListener(eventName,fn,false);else if(element.attachEvent)
element.attachEvent('on'+eventName,fn);}</script> <script type="text/javascript">(function(w,d,s,p){let f=d.getElementsByTagName(s)[0],j=d.createElement(s);j.id='flytedigital';j.async=true;j.src='https://digital.flytedesk.com/js/head.js#'+p;f.parentNode.insertBefore(j,f);})(window,document,'script','8b830333-ba93-41c6-b79d-21170d819254');</script>   <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');ga('create','UA-54288167-1','auto');ga('send','pageview');</script> </head><body><div id="fb-root"></div> <script>/*<![CDATA[*/(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id))return;js=d.createElement(s);js.id=id;js.src='https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v3.1&appId=739309339531216&autoLogAppEvents=1';fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));/*]]>*/</script> <div class="container"><div class="row my-4"><div class="col-12"><div class="row"><div class="col-md-6 col-12"> <a id="masthead" href="https://tuftsdaily.com"><h1 class="mb-0"> <span>T</span>he <span>T</span>ufts <span>D</span>aily</h1><h2 class="d-none d-md-block">The independent student newspaper of Tufts University</h2> </a></div><div class="col-md-3 order-md-first col-12 align-self-end justify-content-md-start align-items-end"> <nav class="navbar navbar-light navbar-expand justify-content-md-start p-0 mb-md-2" id="nav-mini-left"><div id="nav-mini-left-collapse" class="collapse navbar-collapse justify-content-md-start justify-content-center"><ul id="menu-new-mini-left" class="navbar-nav"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-203516" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-203516 nav-item"><a title="Today&#039;s Issue" target="_blank" href="https://issuu.com/tuftsdaily/docs/bwnov5" class="nav-link">Today&#8217;s Issue</a></li></ul></div>                        </nav></div><div class="col-md-3 col-12 align-self-end justify-content-md-end align-items-end"><form class="d-none d-md-block" action="/" method="GET"> <input type="text" name="s" class="form-control rounded-0 d-none d-md-block" placeholder="Search"></form> <nav class="navbar navbar-light navbar-expand justify-content-md-end p-0 mb-2" id="nav-mini-right"><div id="nav-mini-right-collapse" class="collapse navbar-collapse justify-content-md-end justify-content-center"><ul id="menu-new-mini-right" class="navbar-nav"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201509" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-201509 nav-item"><a title="Contact" href="https://tuftsdaily.com/contact/" class="nav-link">Contact</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201510" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-201510 nav-item"><a title="Advertise" href="https://tuftsdaily.com/advertise/" class="nav-link">Advertise</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201511" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-201511 nav-item"><a title="About" href="https://tuftsdaily.com/about/" class="nav-link">About</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201512" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-201512 nav-item"><a title="Donate" href="https://tuftsgiving.org/giving-form.html?id=1&#038;showarea=AR000684&#038;areaid=333&#038;appealcode=A9970" class="nav-link">Donate</a></li></ul></div>                        </nav></div></div><hr class="masthead-bar"><hr class="masthead-bar"><nav class="navbar navbar-expand-lg navbar-light" id="nav-main"> <button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#nav-main-collapse" aria-controls="nav-main-collapse" aria-expanded="false" aria-label="Toggle navigation"> <span class="navbar-toggler-icon"></span> </button><div id="nav-main-collapse" class="collapse navbar-collapse"><ul id="menu-new-main-nav" class="navbar-nav mr-auto"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201500" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201500 nav-item"><a title="News" href="https://tuftsdaily.com/category/news/" class="nav-link">News</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201498" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent active menu-item-201498 nav-item"><a title="Features" href="https://tuftsdaily.com/category/features/" class="nav-link">Features</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201499" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201499 nav-item"><a title="Investigative" href="https://tuftsdaily.com/category/investigative/" class="nav-link">Investigative</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201503" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201503 nav-item"><a title="Multimedia" href="https://tuftsdaily.com/category/multimedia/" class="nav-link">Multimedia</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201497" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201497 nav-item"><a title="Arts" href="https://tuftsdaily.com/category/arts/" class="nav-link">Arts</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201501" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-201501 nav-item"><a title="Opinion" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle nav-link" id="menu-item-dropdown-201501">Opinion</a><ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-201501" role="menu"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201506" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201506 nav-item"><a title="Opinion" href="https://tuftsdaily.com/category/opinion/" class="dropdown-item">Opinion</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201505" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201505 nav-item"><a title="Editorial" href="https://tuftsdaily.com/category/opinion/editorial/" class="dropdown-item">Editorial</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201507 nav-item"><a title="Advice" href="https://tuftsdaily.com/category/advice/" class="dropdown-item">Advice</a></li></ul></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201502" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-201502 nav-item"><a title="Sports" href="https://tuftsdaily.com/category/sports/" class="nav-link">Sports</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-201504" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent active menu-item-201504 nav-item"><a title="Columns" href="https://tuftsdaily.com/category/columns/" class="nav-link">Columns</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-226594" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children dropdown menu-item-226594 nav-item"><a title="Audio" href="#" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false" class="dropdown-toggle nav-link" id="menu-item-dropdown-226594">Audio</a><ul class="dropdown-menu" aria-labelledby="menu-item-dropdown-226594" role="menu"><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-226604" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-226604 nav-item"><a title="The Rewind" href="https://tuftsdaily.com/audio/2019/11/04/the-rewind/" class="dropdown-item">The Rewind</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-226596" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-226596 nav-item"><a title="Out of Curiosity" href="https://tuftsdaily.com/audio/2019/11/04/out-of-curiosity/" class="dropdown-item">Out of Curiosity</a></li><li itemscope="itemscope" itemtype="https://www.schema.org/SiteNavigationElement" id="menu-item-226595" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-226595 nav-item"><a title="Love Is Dead at Tufts" href="https://tuftsdaily.com/audio/2019/11/04/love-dead-tufts/" class="dropdown-item">Love Is Dead at Tufts</a></li></ul></li></ul></div> </nav></div></div><div class="row"><div class="col-12 col-md-8 main-container"><div class="row ad-row mb-3 d-none d-md-block"><div class="col-12"><div class="ad d-flex justify-content-center"><div class="flytead leaderboard"></div></div></div></div><div class="row"><div class="col-12 category-feature"><div class="card rounded-0 border-0"><div class="card-body"><h5 class="font-superclarendon"> Somerville with Townie Tim: Getting around</h5><div class="font-avenir font-size-xs gray-1 author"> <a href="https://tuftsdaily.com/author/naterubright/" title="Posts by Nate Rubright" class="author url fn" rel="author">Nate Rubright</a></div><div class="font-avenir font-size-xxs gray-1"> <a href="https://tuftsdaily.com/features/2019/11/06/somerville-townie-tim-getting-around/"> November 6, 2019                            </a></div><hr/></div><div class="card-body"><div class="content"><p><span style="font-weight: 400;">Sometimes this column is just a local townie going on a curmudgeonly rant, and that is totally going to be the case this week. Just make sure you remember the following column is my mostly sarcastic way of getting some catharsis from frustrating situations. In this case, it&#8217;s not you, it&#8217;s not me, it&#8217;s the fact that this city was </span><span style="font-weight: 400;">built almost 200 years ago.</span></p><p><span style="font-weight: 400;">When they started digging out the horse trenches that would become the roads of this town, city planning wasn&#8217;t really a thing. Basically, they just looked over yonder and declared that “there” might be a good place to go and then set out in a straight shot. This mentality, plus time and people, resulted in the convoluted mess of roads, paths and intersections that connect </span><span style="font-weight: 400;">Somerville</span><span style="font-weight: 400;"> today.</span></p><p><span style="font-weight: 400;">Let’s start with the roads. Having a street that is actually 1.5 lanes but still has cars going in both directions is a </span><span style="font-weight: 400;">Boston</span><span style="font-weight: 400;"> speciality. Driving down them is a game of low-stakes chicken with the opposing traffic to see who will pull into a driveway first. If you are lucky, there are some parking spots you can swoop into, but come on, that is rarely the case.</span></p><p><span style="font-weight: 400;">Next, we have the walking paths. The community path is a wonder of city planning, and I have absolutely no complaints about it, so it gets a big-time pass from my derision. Instead, let’s talk about every other sidewalk in this city. Some are totally legit and support the free passage of people walking in both directions. But, you don’t have to go far to get to that one bottleneck where someone thought a tree would be a good addition and went ahead and took approximately 60% of the cement off the sidewalk to plant it. This also sets up a nice game of “who gets to go” when it’s raining and that tree has just made a big puddle of mud.</span></p><p><span style="font-weight: 400;">Lastly, we have the places where it all comes together: intersections. It almost seems like every intersection in </span><span style="font-weight: 400;">Somerville</span><span style="font-weight: 400;"> has some sort of catch, whether it’s a no turn on red, a crosswalk button that is just for show or a stop sign that is falsely interpreted as a soft yield.</span></p><p><span style="font-weight: 400;">Take for example where </span><span style="font-weight: 400;">Highland Avenue</span><span style="font-weight: 400;"> meets </span><span style="font-weight: 400;">Davis Square</span><span style="font-weight: 400;">. Here you have the ultimate combination of confusing pedestrian, bicycle and car interactions that you could ask for. Basically, a one way road with a bike lane hits the </span><span style="font-weight: 400;">Square</span><span style="font-weight: 400;"> and splits into four options. Normally, you get a green, then a red and a crossing signal. But wait, the red light is on, there is a right turn green arrow, but there are no cars in that lane. Looks safe to cross, right? One pedestrian tries to catch the opportunity even through the walk sign isn’t on. Then folks around them have no idea what&#8217;s going on, so they go too, and all of a sudden everything turns green again as we have a honking mess. I am currently pitching a no-hitter on not seeing this happen.</span></p></div><hr></div></div></div></div></div><div class="col-12 col-md-4 mt-3 mt-md-0 sidebar-container"><div class="row mb-4"><div class="col-12 top-stories"><div class="card rounded-0 border-0"><div class="card-body p-3 py-2"><h6 class="card-title font-avenir font-size-xs">Top This Week</h6><ol class="list-group list-group-flush"><li class="list-group-item px-0 py-1 border-gray-3"><div class="d-flex"><a href="https://tuftsdaily.com/news/2019/11/05/final-days-campaign-somerville-mayoral-candidates-talk-tough-tufts/" class="flex-shrink-1 mr-2 align-self-center"><img width="150" height="150" src="https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-150x150.jpg" class="post-thumb wp-post-image" alt="" srcset="https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-150x150.jpg 150w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-32x32.jpg 32w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-50x50.jpg 50w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-64x64.jpg 64w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-96x96.jpg 96w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-128x128.jpg 128w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-200x200.jpg 200w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-300x300.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><div class="d-flex flex-column align-self-center w-100"><div class="font-superclarendon font-size-xxs" style="min-height: 2.2rem"><a href="https://tuftsdaily.com/news/2019/11/05/final-days-campaign-somerville-mayoral-candidates-talk-tough-tufts/" title="In final days of campaign, both Somerville mayoral candidates talk tough on Tufts">In final days of campaign, both Somerville mayoral candidates talk tough on Tufts</a></div><div class="d-flex justify-content-between align-items-baseline"><span class="gray-1 font-size-xs font-avenir m-0 author"><a href="https://tuftsdaily.com/author/athompson/" title="Posts by Alexander Thompson" class="author url fn" rel="author">Alexander Thompson</a></span><span class="gray-2 font-size-xs font-avenir m-0 flex-shrink-0">November 5, 2019</span></div></div></div></li><li class="list-group-item px-0 py-1 border-gray-3"><div class="d-flex"><a href="https://tuftsdaily.com/opinion/2009/10/29/black-solidarity-day-what-does-it-mean/" class="flex-shrink-1 mr-2 align-self-center"></a><div class="d-flex flex-column align-self-center w-100"><div class="font-superclarendon font-size-xxs" style="min-height: 2.2rem"><a href="https://tuftsdaily.com/opinion/2009/10/29/black-solidarity-day-what-does-it-mean/" title="Black Solidarity Day: What does it mean?">Black Solidarity Day: What does it mean?</a></div><div class="d-flex justify-content-between align-items-baseline"><span class="gray-1 font-size-xs font-avenir m-0 author"><a href="https://tuftsdaily.com/author/ben-serrano/" title="Posts by Ben Serrano" class="author url fn" rel="author">Ben Serrano</a></span><span class="gray-2 font-size-xs font-avenir m-0 flex-shrink-0">October 29, 2009</span></div></div></div></li><li class="list-group-item px-0 py-1 border-gray-3"><div class="d-flex"><a href="https://tuftsdaily.com/news/2019/11/04/somerville-city-council-contenders-share-thoughts-tufts-issues/" class="flex-shrink-1 mr-2 align-self-center"><img width="150" height="150" src="https://cdn.tuftsdaily.com/2019/11/polling-150x150.jpg" class="post-thumb wp-post-image" alt="" srcset="https://cdn.tuftsdaily.com/2019/11/polling-150x150.jpg 150w, https://cdn.tuftsdaily.com/2019/11/polling-32x32.jpg 32w, https://cdn.tuftsdaily.com/2019/11/polling-50x50.jpg 50w, https://cdn.tuftsdaily.com/2019/11/polling-64x64.jpg 64w, https://cdn.tuftsdaily.com/2019/11/polling-96x96.jpg 96w, https://cdn.tuftsdaily.com/2019/11/polling-128x128.jpg 128w, https://cdn.tuftsdaily.com/2019/11/polling-200x200.jpg 200w, https://cdn.tuftsdaily.com/2019/11/polling-300x300.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><div class="d-flex flex-column align-self-center w-100"><div class="font-superclarendon font-size-xxs" style="min-height: 2.2rem"><a href="https://tuftsdaily.com/news/2019/11/04/somerville-city-council-contenders-share-thoughts-tufts-issues/" title="Somerville City Council contenders share thoughts on Tufts issues">Somerville City Council contenders share thoughts on Tufts issues</a></div><div class="d-flex justify-content-between align-items-baseline"><span class="gray-1 font-size-xs font-avenir m-0 author"><a href="https://tuftsdaily.com/author/athompson/" title="Posts by Alexander Thompson" class="author url fn" rel="author">Alexander Thompson</a></span><span class="gray-2 font-size-xs font-avenir m-0 flex-shrink-0">November 4, 2019</span></div></div></div></li><li class="list-group-item px-0 py-1 border-gray-3"><div class="d-flex"><a href="https://tuftsdaily.com/news/2019/09/11/curtatone-wins-mayoral-prelim-challenger-sees-hope-general/" class="flex-shrink-1 mr-2 align-self-center"><img width="150" height="150" src="https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-150x150.jpg" class="post-thumb wp-post-image" alt="" srcset="https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-150x150.jpg 150w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-32x32.jpg 32w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-50x50.jpg 50w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-64x64.jpg 64w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-96x96.jpg 96w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-128x128.jpg 128w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-200x200.jpg 200w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-300x300.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><div class="d-flex flex-column align-self-center w-100"><div class="font-superclarendon font-size-xxs" style="min-height: 2.2rem"><a href="https://tuftsdaily.com/news/2019/09/11/curtatone-wins-mayoral-prelim-challenger-sees-hope-general/" title="Curtatone wins mayoral prelim, challenger sees hope for general">Curtatone wins mayoral prelim, challenger sees hope for general</a></div><div class="d-flex justify-content-between align-items-baseline"><span class="gray-1 font-size-xs font-avenir m-0 author"><a href="https://tuftsdaily.com/author/athompson/" title="Posts by Alexander Thompson" class="author url fn" rel="author">Alexander Thompson</a></span><span class="gray-2 font-size-xs font-avenir m-0 flex-shrink-0">September 11, 2019</span></div></div></div></li><li class="list-group-item px-0 py-1 border-gray-3"><div class="d-flex"><a href="https://tuftsdaily.com/news/2019/11/01/tufts-medical-students-confront-monaco-regarding-sacklers-stern-report/" class="flex-shrink-1 mr-2 align-self-center"></a><div class="d-flex flex-column align-self-center w-100"><div class="font-superclarendon font-size-xxs" style="min-height: 2.2rem"><a href="https://tuftsdaily.com/news/2019/11/01/tufts-medical-students-confront-monaco-regarding-sacklers-stern-report/" title="Tufts medical students confront Monaco regarding Sacklers, Stern report">Tufts medical students confront Monaco regarding Sacklers, Stern report</a></div><div class="d-flex justify-content-between align-items-baseline"><span class="gray-1 font-size-xs font-avenir m-0 author"><a href="https://tuftsdaily.com/author/austinclementi/" title="Posts by Austin Clementi" class="author url fn" rel="author">Austin Clementi</a></span><span class="gray-2 font-size-xs font-avenir m-0 flex-shrink-0">November 1, 2019</span></div></div></div></li></ol></div></div></div></div><div class="row mb-4"><div class="col-12 top-stories"><div class="card rounded-0 border-0"><div class="card-body p-3 py-2"><h6 class="card-title font-avenir font-size-xs">Trending</h6><ol class="list-group list-group-flush"><li class="list-group-item px-0 py-1 border-gray-3"><div class="d-flex"><a href="https://tuftsdaily.com/news/2019/11/05/final-days-campaign-somerville-mayoral-candidates-talk-tough-tufts/" class="flex-shrink-1 mr-2 align-self-center"><img width="150" height="150" src="https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-150x150.jpg" class="post-thumb wp-post-image" alt="" srcset="https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-150x150.jpg 150w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-32x32.jpg 32w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-50x50.jpg 50w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-64x64.jpg 64w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-96x96.jpg 96w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-128x128.jpg 128w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-200x200.jpg 200w, https://cdn.tuftsdaily.com/2019/11/IMG_6235-1-300x300.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><div class="d-flex flex-column align-self-center w-100"><div class="font-superclarendon font-size-xxs" style="min-height: 2.2rem"><a href="https://tuftsdaily.com/news/2019/11/05/final-days-campaign-somerville-mayoral-candidates-talk-tough-tufts/" title="In final days of campaign, both Somerville mayoral candidates talk tough on Tufts">In final days of campaign, both Somerville mayoral candidates talk tough on Tufts</a></div><div class="d-flex justify-content-between align-items-baseline"><span class="gray-1 font-size-xs font-avenir m-0 author"><a href="https://tuftsdaily.com/author/athompson/" title="Posts by Alexander Thompson" class="author url fn" rel="author">Alexander Thompson</a></span><span class="gray-2 font-size-xs font-avenir m-0 flex-shrink-0">November 5, 2019</span></div></div></div></li><li class="list-group-item px-0 py-1 border-gray-3"><div class="d-flex"><a href="https://tuftsdaily.com/news/2019/11/04/somerville-city-council-contenders-share-thoughts-tufts-issues/" class="flex-shrink-1 mr-2 align-self-center"><img width="150" height="150" src="https://cdn.tuftsdaily.com/2019/11/polling-150x150.jpg" class="post-thumb wp-post-image" alt="" srcset="https://cdn.tuftsdaily.com/2019/11/polling-150x150.jpg 150w, https://cdn.tuftsdaily.com/2019/11/polling-32x32.jpg 32w, https://cdn.tuftsdaily.com/2019/11/polling-50x50.jpg 50w, https://cdn.tuftsdaily.com/2019/11/polling-64x64.jpg 64w, https://cdn.tuftsdaily.com/2019/11/polling-96x96.jpg 96w, https://cdn.tuftsdaily.com/2019/11/polling-128x128.jpg 128w, https://cdn.tuftsdaily.com/2019/11/polling-200x200.jpg 200w, https://cdn.tuftsdaily.com/2019/11/polling-300x300.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><div class="d-flex flex-column align-self-center w-100"><div class="font-superclarendon font-size-xxs" style="min-height: 2.2rem"><a href="https://tuftsdaily.com/news/2019/11/04/somerville-city-council-contenders-share-thoughts-tufts-issues/" title="Somerville City Council contenders share thoughts on Tufts issues">Somerville City Council contenders share thoughts on Tufts issues</a></div><div class="d-flex justify-content-between align-items-baseline"><span class="gray-1 font-size-xs font-avenir m-0 author"><a href="https://tuftsdaily.com/author/athompson/" title="Posts by Alexander Thompson" class="author url fn" rel="author">Alexander Thompson</a></span><span class="gray-2 font-size-xs font-avenir m-0 flex-shrink-0">November 4, 2019</span></div></div></div></li><li class="list-group-item px-0 py-1 border-gray-3"><div class="d-flex"><a href="https://tuftsdaily.com/news/2019/09/11/curtatone-wins-mayoral-prelim-challenger-sees-hope-general/" class="flex-shrink-1 mr-2 align-self-center"><img width="150" height="150" src="https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-150x150.jpg" class="post-thumb wp-post-image" alt="" srcset="https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-150x150.jpg 150w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-32x32.jpg 32w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-50x50.jpg 50w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-64x64.jpg 64w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-96x96.jpg 96w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-128x128.jpg 128w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-200x200.jpg 200w, https://cdn.tuftsdaily.com/2019/09/IMG_1192-3-300x300.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><div class="d-flex flex-column align-self-center w-100"><div class="font-superclarendon font-size-xxs" style="min-height: 2.2rem"><a href="https://tuftsdaily.com/news/2019/09/11/curtatone-wins-mayoral-prelim-challenger-sees-hope-general/" title="Curtatone wins mayoral prelim, challenger sees hope for general">Curtatone wins mayoral prelim, challenger sees hope for general</a></div><div class="d-flex justify-content-between align-items-baseline"><span class="gray-1 font-size-xs font-avenir m-0 author"><a href="https://tuftsdaily.com/author/athompson/" title="Posts by Alexander Thompson" class="author url fn" rel="author">Alexander Thompson</a></span><span class="gray-2 font-size-xs font-avenir m-0 flex-shrink-0">September 11, 2019</span></div></div></div></li><li class="list-group-item px-0 py-1 border-gray-3"><div class="d-flex"><a href="https://tuftsdaily.com/features/2019/11/05/national-period-movement-comes-tufts/" class="flex-shrink-1 mr-2 align-self-center"><img width="150" height="150" src="https://cdn.tuftsdaily.com/2019/11/IMG_0148-copy-150x150.jpg" class="post-thumb wp-post-image" alt="" srcset="https://cdn.tuftsdaily.com/2019/11/IMG_0148-copy-150x150.jpg 150w, https://cdn.tuftsdaily.com/2019/11/IMG_0148-copy-32x32.jpg 32w, https://cdn.tuftsdaily.com/2019/11/IMG_0148-copy-50x50.jpg 50w, https://cdn.tuftsdaily.com/2019/11/IMG_0148-copy-64x64.jpg 64w, https://cdn.tuftsdaily.com/2019/11/IMG_0148-copy-96x96.jpg 96w, https://cdn.tuftsdaily.com/2019/11/IMG_0148-copy-128x128.jpg 128w, https://cdn.tuftsdaily.com/2019/11/IMG_0148-copy-200x200.jpg 200w, https://cdn.tuftsdaily.com/2019/11/IMG_0148-copy-300x300.jpg 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><div class="d-flex flex-column align-self-center w-100"><div class="font-superclarendon font-size-xxs" style="min-height: 2.2rem"><a href="https://tuftsdaily.com/features/2019/11/05/national-period-movement-comes-tufts/" title="National PERIOD movement comes to Tufts">National PERIOD movement comes to Tufts</a></div><div class="d-flex justify-content-between align-items-baseline"><span class="gray-1 font-size-xs font-avenir m-0 author"><a href="https://tuftsdaily.com/author/jilliancollins/" title="Posts by Jillian Collins" class="author url fn" rel="author">Jillian Collins</a></span><span class="gray-2 font-size-xs font-avenir m-0 flex-shrink-0">November 5, 2019</span></div></div></div></li><li class="list-group-item px-0 py-1 border-gray-3"><div class="d-flex"><a href="https://tuftsdaily.com/opinion/2009/10/29/black-solidarity-day-what-does-it-mean/" class="flex-shrink-1 mr-2 align-self-center"></a><div class="d-flex flex-column align-self-center w-100"><div class="font-superclarendon font-size-xxs" style="min-height: 2.2rem"><a href="https://tuftsdaily.com/opinion/2009/10/29/black-solidarity-day-what-does-it-mean/" title="Black Solidarity Day: What does it mean?">Black Solidarity Day: What does it mean?</a></div><div class="d-flex justify-content-between align-items-baseline"><span class="gray-1 font-size-xs font-avenir m-0 author"><a href="https://tuftsdaily.com/author/ben-serrano/" title="Posts by Ben Serrano" class="author url fn" rel="author">Ben Serrano</a></span><span class="gray-2 font-size-xs font-avenir m-0 flex-shrink-0">October 29, 2009</span></div></div></div></li></ol></div></div></div></div><div class="row mb-4"><div class="col-12"><div id="bs_zones-2" class="widget cf bs_zones"><div><broadstreet-zone zone-id="74298" keywords="not_home_page,not_landing_page,is_article_page,opinion,black-solidarity-day-what-does-it-mean,post" soft-keywords="true"></broadstreet-zone></div></div><div id="text-11" class="widget cf widget_text"><div class="textwidget"><div class="ad d-flex justify-content-center mb-3"><div class="flytead rectangle"></div></div></div></div><div id="text-7" class="widget cf widget_text"><div class="textwidget"><div class="fb-page" data-href="https://www.facebook.com/thetuftsdaily/" data-tabs="timeline" data-small-header="true" data-adapt-container-width="true" data-hide-cover="true" data-show-facepile="false" height="1000"><blockquote cite="https://www.facebook.com/thetuftsdaily/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/thetuftsdaily/">The Tufts Daily</a></blockquote></div></div></div><div id="text-9" class="widget cf widget_text"><div class="textwidget"></div></div><div id="text-13" class="widget cf widget_text"><div class="textwidget"></div></div></div></div></div></div><div class="row font-avenir font-size-xs mt-5"><div class="col-12 col-md-5"> COPYRIGHT 2019 THE TUFTS DAILY. ALL RIGHTS RESERVED.</div><div class="col-12 col-md-7 align-items-flex-end"><ul id="menu-new-footer" class="list-inline d-flex justify-content-end"><li id="menu-item-201513" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-201513"><a href="https://www.facebook.com/pages/The-Tufts-Daily/40213714188">Facebook</a></li><li id="menu-item-201514" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-201514"><a href="https://twitter.com/tuftsdaily">Twitter</a></li><li id="menu-item-201515" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-201515"><a href="https://instagram.com/tuftsdaily">Instagram</a></li><li id="menu-item-214739" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-214739"><a href="http://www.youtube.com/thetuftsdaily">YouTube</a></li></ul></div></div></div>  <script type="text/javascript">/*<![CDATA[*/jQuery(document).ready(function(){jQuery('.description').before('<span><!--INFOLINKS_OFF--></span>');jQuery('.description').after('<span><!--INFOLINKS_ON--></span>');jQuery('#headerimg').before('<span><!--INFOLINKS_OFF--></span>');jQuery('#headerimg').after('<span><!--INFOLINKS_ON--></span>');jQuery('h1').before('<span><!--INFOLINKS_OFF--></span>');jQuery('h1').after('<span><!--INFOLINKS_ON--></span>');jQuery('h1').before('<span><!--INFOLINKS_OFF--></span>');jQuery('h1').after('<span><!--INFOLINKS_ON--></span>');});/*]]>*/</script> <script type="text/javascript">var infolinks_pid=3134022;var infolinks_plugin_version="WP_3.2.3";var infolinks_resources="https://resources.infolinks.com/js";</script> <script type="text/javascript" src="https://resources.infolinks.com/js/infolinks_main.js" ></script> <script data-cfasync='false'>window.broadstreetKeywords=['not_home_page','not_landing_page','is_article_page','opinion','black-solidarity-day-what-does-it-mean','post']</script> <script data-cfasync='false'>window.broadstreetTargets={"pagetype":["post","not_home_page"],"category":["opinion","black-solidarity-day-what-does-it-mean","post"],"url":"black-solidarity-day-what-does-it-mean"};</script> <script data-cfasync='false'>window.broadstreet=window.broadstreet||{run:[]};window.broadstreet.run.push(function(){window.broadstreet.watch({});});</script><script type='text/javascript'>var wpcf7={"apiSettings":{"root":"https:\/\/tuftsdaily.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}},"cached":"1"};</script> <script type='text/javascript' src='https://tuftsdaily.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9.1'></script> <script type='text/javascript' src='https://tuftsdaily.com/wp-content/plugins/aesop-story-engine/public/assets/js/ai-core.min.js?ver=1.9.9.4'></script> <script type='text/javascript' src='https://code.jquery.com/jquery-3.3.1.slim.min.js'></script> <script type='text/javascript' src='https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.0/umd/popper.min.js'></script> <script type='text/javascript' src='https://stackpath.bootstrapcdn.com/bootstrap/4.1.0/js/bootstrap.min.js'></script> <script type='text/javascript' src='https://tuftsdaily.com/wp-includes/js/wp-embed.min.js?ver=4.7.14'></script> </body></html>